1. We're in the beta phase now!

XC11 winding problems

Discussion in 'SIG: Atari 8-Bit Hardware' started by Tharkanoid, Feb 21, 2020.

  1. by Tharkanoid
    Tharkanoid

    Tharkanoid Galley Slave

    Blog Posts:
    0
    Greetings fellow atarians!

    At present I've got a sick xc11 on the desk with a problem of not ffwd/rew.

    This is a work in progress so as I go I will update.

    What I have done so far:
    ====================
    Replaced belts - easy to do, this got the deck playing and loading successfully, but barely able to wind ffwd or rew.

    So greased up cogs/gears, checked everything was free moving and all seems good.

    So the motor is spinning ok but under load it is weak.

    At present I'm investigating the motor transistors and capacitors to see if I can trace the problem. I have the brilliant vulcanman assisting me by sharing his readings from his fully working xc11. Thus I M able to fault find easier.

    Next step is to compare these readings. Please be patient with me as my household is always buisy! :D
    Watch this space:)
     
  2. by Timothy Kline
    Timothy Kline

    Timothy Kline Administrator Staff Member

    Blog Posts:
    3
    Articles:
    4
    _________

    Was a field service manual ever released for the XC11, I'm wondering, and do you already have schematics— if they're available?

    --Tim
    An Atari Owner
     
    Andy Barr and Tharkanoid like this.
  3. by Timothy Kline
    Timothy Kline

    Timothy Kline Administrator Staff Member

    Blog Posts:
    3
    Articles:
    4
  4. by Tharkanoid
    Tharkanoid

    Tharkanoid Galley Slave

    Blog Posts:
    0
    Thanks for the schematic Tim, be good to study it.
    Vulcanman sent me his readings of Various resistors and transistors in the motor circuit, and I've got my supplier (tekkikid) sending me some replacement NPN and PNP motor power transistors.

    I will post my results promptly once I get the parts fitted and tested.

    The excitement is killing :D
    Looked at the schematic, very helpful indeed, thanks again.
    [​IMG]
     

    Attached Files:

    Andy Barr and Timothy Kline like this.
  5. by Andy Barr
    Andy Barr

    Andy Barr Deckhand

    Blog Posts:
    0
    Good luck with that XC11 deck, Tharkanoid - I always felt the XC11 to be the "looker" in the Atari cassette drive stakes. Some of the others just looked clunky or badly built (410 and XC12 spring to mind).

    Keep us updated, fella - a nice little project for a guy of your well-known tape talents.
     
    Tharkanoid likes this.
  6. by Tharkanoid
    Tharkanoid

    Tharkanoid Galley Slave

    Blog Posts:
    0
    Thanks Andy :)
     
    Andy Barr likes this.
  7. by Tharkanoid
    Tharkanoid

    Tharkanoid Galley Slave

    Blog Posts:
    0
    Well after the delay I have good news.
    The xc11 is alive and kicking.

    I ended up replacing the motor driver transistors, this made the problem worse - wasn't expecting that result!
    So I put original tranny's back in and unbelievably it started working as it should. Vulcanman seems to think that it could of been a bad solder connection.

    So there we have it. Anyone with similar problems - defo reflow the solder joints on the transistors, replace the belts, lube the cogs.

    I also replaced the power caps.

    Well worth a fix as it's a great peice of kit.
     
    M.D.Baker likes this.
  8. by Andy Barr
    Andy Barr

    Andy Barr Deckhand

    Blog Posts:
    0
    Brilliant, mate.

    When it comes to tapes, decks, recorders, pinch rollers, capstans, data-corders, you name it cassette-wise, you are the main man, Tharkanoid.

    Now then, this Altai thing is DEAD ON ARRIVAL at the Baz Biome today - not a peep out of it once plugged in - are you up for ANOTHER challenge, oh Thark of the ferric materials?!

    [​IMG]
    ABOVE: Powerless to perform - even with 6V AC transformer - not a peep out of this Altai
     
    Tharkanoid likes this.
  9. M.D.Baker

    M.D.Baker Deckhand

    Blog Posts:
    2
    Is the Altai a tape drive for the Atari?
     
  10. by Tharkanoid
    Tharkanoid

    Tharkanoid Galley Slave

    Blog Posts:
    0
    Sure thing, please send it with the power supply too.

    Probably a bad PSU or a dud diode!
     
    Andy Barr likes this.
  11. by Andy Barr
    Andy Barr

    Andy Barr Deckhand

    Blog Posts:
    0
    Nope, sorry for possibly giving any impression it was (tagging it on to the end of Thark's XC-11 thread).

    It's strictly a generic standard cassette/data recorder for any micro using x2 3.5mm jack leads for loading and saving, Matt.

    Many tharks, Thark - I will send the beast with a tested working power pack (it's definitely a failure inside the Altai) - next week, mate.
     

Share This Page